
DoDEA: Introduction to Macromedia's Dreamweaver 4

DREAMWEAVER COURSE OBJECTIVES

 - Familiarity with the Dreamweaver interface
 - Familiarity with Macromedia's Extension Manager
 - Setup local/remote Web site
 - Create Web Site Homepage
 - Fireworks Integration
 - Create a site-wide template
 - Create Web pages using a Template
 - Publish to the Web site
 - Check a Web page for Accessibility Issues

DREAMWEAVER 4 COURSE SPECIFICS:

HTTP Address:                                                              

Student Username:                                                                    

Student Password:                                                                     

Local Root Folder:                                                                                 

Web Server Student Folder:                                                                               

Lynx Installation Path:                                                                            
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DoDEA: Dreamweaver 4 Lab Exercises

Dreamweaver 4, Lab 1 – Web Site Setup

1.  Start Dreamweaver.

Double-click the Dreamweaver icon or for Windows, click Start > Programs >
Macromedia > Dreamweaver 4.

2.  Define Web Site Parameters.

a.  From the menu bar click Site > New Site.

b.  Click Local Info in the Category text box.

c.  In the Site Name  text box enter WMS.

d.  In the Local Root Folder text box, type in the drive letter and folder specified in the
Dreamweaver 4 Course Specifics, Local Root Folder provided to you earlier (e.g.,
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c:\webdocs) or click the folder icon to navigate to the specified folder.  Open and select it.
(Mac note: Click Choose .)

(Note:  When you setup your Web site, the local root folder should already exist on your
computer.  If not, cancel the Web site setup, create the local root folder on your
computer, and start over.)

e.  In the HTTP Address text box, add the following additional information to the "http://"
as specified in the Dreamweaver 4 Course Specifics provided to you earlier.  Type in
the HTTP Address, followed by a forward slash, "/", and then the information in the
Student Username (e.g., http://192.168.1.1/user1).  Accept the defaults, checked, for
the Refresh Local File List Automatically and Enable Cache.

f. Click Remote Info in the Category text box.

g.  In the Access Type  pulldown, select FTP.
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h. In the FTP Host text box, type in the information from the HTTP Address
(e.g.,192.168.1.1)

i.  In the Host Directory text box, type in the Web Server Student Folder information.

j. In the Login text box, type in the Student Username information.  Do not enter the
password at this time.

k.  Click the Check In/Out checkbox to check it. Accept the defaults, unchecked, for the
Passive FTP and Use Firewall.

l.  In the Check Out Name text box, enter your name.

m.  Click Ok. Click Ok again to the Create Site Cache  alert box.

n. If the Define Sites window is open, click Done or click the "X" to close the Site
Manager window.

3.  Exit Dreamweaver.

To exit Dreamweaver, from the menu bar, click File > Exit.
(Mac note: File > Quit)
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Dreamweaver 4, Lab 2 – Macromedia Extension Manager

1.  Start Dreamweaver.

2.  Start Extension Manager.

From the menu bar click Commands > Manage Extensions.  The Macromedia
Extension Manager window will open.

3.  Install Extensions.

a.  From the menu bar in the Macromedia Extension Manager window click File > Install
Extension.

b.  Navigate to the /Solution/dw_ext folder and click on the first of the three extensions
listed.

c.  Click Install.

d.  Click Accept to accept the license agreement.

e.  Click Ok for the successful installation alert box.  Usage instructions for the extension
will appear in the Extension Manager window.

e.  Repeat steps a. – e. for the remaining two extensions in the folder.

f. From the menu bar in the Macromedia Extension Manager window click File > Exit.

4.  Exit Dreamweaver.

The next time you start Dreamweaver your extensions will be available for use.  The 508
Accessibility Extension may display its license agreement in your browser when you
restart Dreamweaver.  Read the license agreement and close the browser window.
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Dreamweaver 4, Lab 3 – Create the Web Site Index Page

1.  Start Dreamweaver.

If the Site Manager window does not open when you start Dreamweaver, from the menu
bar click Site > Open Site > WMS.  If the Site Manager window opens with
Dreamweaver, simply select the Web site you wish to work with from the Site pulldown.
For our labs, select WMS.

2.  Page Setup.

a.  In the Untitled Document window, from the menu bar, click View > Design.

b.  From the menu bar, click Modify > Page Properties.

c.  In the Title text box type in DoDEA: Wuerkruzen Middle School – Homepage .

d.  In the Background text box type in #FFFFFF for white or use the color selector box.

e.  In the Text text box type in #000000 (zeroes) for black or use the color selector box.

f.  In the Links text box type in #000099 for dark blue or use the color selector box.

g.  In the Visited Links text box type in #000099 for dark blue or use the color selector
box.

h.  Leave all other fields empty with the exception of Document Encoding.  Leave that
pulldown set to Western.  Click Apply and then click Ok.

i.  From the menu bar, click Insert > Head Tags > Meta .

j.  In the Value text box, type in Author.

k.  In the large Content text box type in your first initial and last name.  Click Ok.
(Hint: If you make a mistake, click  View > Code and fix the mistake in the HTML source
code. Click  View > Design to switch back to design view.)

l.   Repeat i. – k.  for the values of Designer and Approval.
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3.  Insert Image.

a. In the Objects panel, click on the Insert Image object tool (1st tool, left-hand column)
and drag it over onto your empty Web page window.
(Hint: If you do not see the Objects panel, click Window on the menu bar and click
Objects.)

b.  Navigate to the local root folder / images folder and click on wms-logo.gif.  Click
Select. (Mac note: Click Open)

c.  Click Ok to the Document Relative  alert box.
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d.  In the Property Inspector panel, Alt text box type in Wuerkruzen Middle School –
Department of Defense Education Activity.
 (Hint: If you do not see the Property Inspector panel, click Window on the menu bar and
click Properties. )

e.  In the Border text box type in 0 (zero) and click the left align button to the right of the
Border text box.
(Hint: If you do not see the Border text box, click the small dark gray triangle at the
bottom right corner of the Property Inspector panel.)

f.  Place your cursor below the graphic, click, and press the <Enter Key> to "space"
down.

4.  Save Work in Progress.  Saving the file frequently avoids losing work and allows
Dreamweaver to update it link references.

a.  From the menu bar, click File > Save As.

b.  Navigate to your local root folder and type in index.html.  Click Save .

5.  Insert Table.

a. In the Objects panel, click on the Insert Table object tool (2nd down, left-hand column)
and drag it over onto your Web page window below the graphic and blank line you just
created.

b.  In the Insert Table window enter type in Rows: 3, Cell Padding: 0 (zero), Columns: 4,
Cell Spacing: 0 (zero), Width: 625, select pixels from the pulldown, and Border: 0 (zero).
Click Ok.

c.  Using your cursor, click on the second table cell from the left in the first row and drag
the cursor over to the third cell in that row.  When the two cells are highlighted, release
the mouse button.

d.  With your cursor in the highlighted cells, right click, and click Table > Merge Cells.
 (Hint: If you can not right click, from the menu bar, click Modify > Table > Merge Cells.)

e.  Place your cursor in the first cell of the first row and click.  In the Property Inspector's
W (width) text box, type in 20%.  Repeat this step for the last cell in the first row also.
(Hint: If you do not see the W text box, click the small dark gray triangle at the bottom
right corner of the Property Inspector panel.)
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6.  Insert Graphic.

a.  Using the Insert Image  tool, click and drag into the area created by the merged cells.
Release the mouse button.

b.  Navigate to the local root folder / images folder and click on wms-bldg.jpg.  Click
Select.

c.  Click Ok to the Document Relative  alert box.

d.  In the Property Inspector panel, Alt text box type in Photograph of School Building.

e.  In the Border text box type in 0 (zero) and click the center align button to the right of
the Border pulldown.

7.  Insert Fireworks Code.

a. In the Objects panel, click on the Insert Fireworks HTML tool (6th down, left-hand
column) and drag it over into the first cell, first row of the table and release the mouse
button.

b.  When the Insert Fireworks HTML window opens, click Browse  to navigate to the
local root folder / images folder, wms-menu.htm, and click Open and then Ok.

8.  Adding Links.

a.  In the second cell, second row of the table type in Barbara Davis, Principal.

b.  Using your cursor highlight, the words you just entered.

c.  In the Property Inspector, change the font in the pulldown from Default Font to
Verdana, Helvetica, Arial.

d.  Change the size pulldown to 2 and type in the color #000099 (dark blue).  You can
also use the color selector to pick a font color.

e.  In the Vert pulldown, select Top.

f.  Highlight the words Barbara Davis.  In the Property Inspector, Link text box enter
mailto:principal@wms.odedodea.edu .  When you click off the words, you will notice
the name is now a hyperlink.

g.  If the third cell in the second row has become very small, place your cursor on the
dashed line between the second and third cell.  Click and drag to your left until the
second and third cells are roughly the same size.

h.  In the third cell, second row of the table type in Thomas Smith, Asst. Principal.

i.  Using your cursor highlight, the words you just entered.
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j.  In the Property Inspector, change the font in the pulldown from Default Font to
Verdana, Helvetica, Arial.

k.  Change the size pulldown to 2 and type in the color #000099 (dark blue) and click the
right align button.

l.  In the Vert pulldown, select Top.

m.  Highlight the words Thomas Smith.  In the Property Inspector, Link text box enter
mailto:asstprincipal@wms.odedodea.edu .

9.  Adding Text.

a.  Using your cursor, click on the second table cell from the left in the last row and drag
the cursor over to the third cell in that row.  When the two cells are highlighted, release
the mouse button.

b.  With your cursor in the highlighted cells, right click, and click Table > Merge Cells.
 (Hint: If you can not right click, from the menu bar, click Modify > Table > Merge Cells.)

c.  In the cells you just merged, type in the following text:

On behalf of myself, the Assistant Principal, faculty, and staff, welcome to
Wuerkruzen Middle School. We look forward to providing an exemplary
educational experience that will inspire and prepare our students for
success in a global environment.

d.  Using your cursor highlight, the block of text you just entered.

e.  In the Property Inspector, change the font in the pulldown from Default Font to Times
New Roman, Size pulldown to 3, type in the color #000000 (black), click the I button for
italics, and click the align center button.

10.  Adding Hyperlinks.

a.  Click on the first table cell in the last row.

b.  Type in Privacy and Security Notice and press the <Enter> key.

c.  Type in DoDEA Homepage  and press the <Enter> key.

d. In the Objects panel, click on the Insert Date tool (5th down, left-hand column) and
drag it over into the first cell, last row of the table, below the words DoDEA Homepage,
and release the mouse button.

e.  In the Insert Date window, select [No Day] for the Day Format, 03/07/1974 for the
Date Format, and [No Time] for the Time Format.

f.  Click the radio button for Update Automatically on Save .  Click Ok.

g.  Highlight the words Privacy and Security Notice, DoDEA Homepage , and the date.
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h.  In the Property Inspector, change the font in the pulldown from Default Font to
Verdana, Helvetica, Arial.

i.  Change the Size pulldown to 2, type in the color #000099 (dark blue), and click the left
align button.

j.  In the Vert pulldown, select Top.

k. Highlight the words Privacy and Security Notice .  In the Property Inspector, Link text
box enter http://www.odedodea.edu/images/disclaim.htm .
(Note: This is an absolute hyperlink reference.)

l. Highlight the words DoDEA Homepage .  In the Property Inspector, Link text box enter
http://www.odedodea.edu.

m.  Click File > Save to save the page.  If you did not previously save your Web page, a.
From the menu bar, click File > Save As. Navigate to your local root folder and type in
index.html.  Click Save.

11.  Adjust and Spell Check the Web Page.

a.  Using your cursor, place it on the dashed lines between table cells and rows.  Click
and drag to adjust cell and row sizes as needed.

b.  From the menu bar, click Text > Check Spelling.  Using the Ignore and Change
buttons, correct any spelling errors you may have made while you were typing.

c.  Click Ok when finished.

12.  Fix Alt Tags when Using Fireworks HTML.

a.  From the menu bar click Edit > Find and Replace.

b.  Set the Find In: pulldown to Current Document.

c.  Set the Search For: pulldown to Source Code  and in the text box to the right type in
spacer.gif" (Do not forget the ending double quotation mark).

d.  In the Replace With: text box type in spacer.gif" alt="" (two double quotation marks
with nothing in between).

e.  Click Replace All. Click Ok to the replacement warning and click Close  when
finished.  If a Code Inspector window opens, you can close it too.

f.  From the menu bar click File > Save.
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13.  Preview the Web Page.

a.  From the menu bar, click File > Preview in Browser.

b.  Select one of the browsers listed.  If no browser is listed, click Edit Browser List and
click the + sign.  Type in a name and navigate on the hard drive to where a browser is
located.  Click the program file and click Open.  Click Ok.

c.  When finished viewing the page, close the browser.

14.  Exit Dreamweaver.
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Dreamweaver 4, Lab 4 – Publish Web Site Files

1.  Start Dreamweaver.

Go to the Site Manager window and select the Web site you wish to work with from the
Site pulldown.  If WMS is not already selected, select WMS. (Mac note: If the Site
Defintion window  opens, click  Ok to continue.)

2.  Upload files.

a.  Click the index.html file in the Local Folder side of the Window and click the Check-
In icon.  Anytime you are prompted to enter you password, type in your Student
Password and click Ok.  This is required to complete the connection to the Web Server

b. Since this is the first time these files are being sent to the web server, when prompted
to include Dependent Files, click Yes.  The files including all the required graphic files
you built earlier will be transferred to the Web server.

c.  Click the Netscape Navigator or MS Internet Explorer icon on the desktop or for
Windows, click Start > Programs > Netscape Communicator or Internet Explorer.

d.  In the browser window, Netsite  or Address text box type in http:// followed by the
HTTP Address, a forward slash "/", and your Student username.  You should see your
WMS Homepage displayed.

3.  Make a Change to a Web Page.

a.  Return to the Site Manager Window.  Click on the index.html page in either the local
or remote site folder window.  Click on the Check-out icon.

b.  When prompted to Include Dependent Files, click No.  You will see a checkmark
appear next to the file's name.
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c.  Click on the scroll bar at the bottom of the Site Manager window and scroll right.
You should see you have the index.html file "checked-out" by you.

d.  Double click the index.html file to open it up in Dreamweaver.

e.  Highlight the name of the Assistant Principal and change it to whatever name you
choose (e.g., James Dean).

f.  From the menu bar click, File > Save.

g.  Go to the Site Manager window and in the Local Folder window, click the index.html
file, and click the Check-in icon.  Your updated Web page will be transferred to the Web
Server.  When prompted to Include Dependent Files, click No since we made no
additions or changes to the Web page graphics or scripts.

h.  Open your browser window and click Reload or Refresh.  If you closed your browser
complete steps c. – d. again to restart it.

i.  Close the browser window.  Click the "X" at the top corner of the window or, from the
menu bar, click File > Exit, Close , or Quit.

4.  Exit Dreamweaver.
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Dreamweaver 4, Lab 5 – Building a Web Site Template

1.  Start Dreamweaver.

Go to the Site Manager window and select the Web site you wish to work with from the
Site pulldown.  If not selected, select WMS.

2.  Page Setup.

a.  In the Untitled Document window, from the menu bar, click View > Design.
(Hint: If there is no Untitled Document window available, from the Site Manager menu
bar, click File > New.)

b.  From the menu bar, click Modify > Page Properties.

c.  In the Title text box type in DoDEA: Wuerkruzen Middle School.

d.  In the Background text box type in #FFFFFF for white or use the color selector box.

e.  In the Text text box type in #000000 (zeroes) for black or use the color selector box.

f.  In the Links text box type in #000099 for dark blue or use the color selector box.



15

g.  In the Visited Links text box type in #000099 for dark blue or use the color selector
box.

h.  Leave all other fields empty with the exception of Document Encoding.  Leave that
pulldown set to Western.  Click Apply and then click Ok.

i.  From the menu bar, click Insert > Head Tags > Meta .

j.  In the Value text box, type in Author.

k.  In the large Content text box type in your first initial and last name.  Click Ok.

l.   Repeat i. – k.  for the values of Designer and Approval.

3.  Insert Fireworks Code.

a. In the Objects panel, click on the Insert Fireworks HTML tool (6th down, left-hand
column), drag it onto the blank Web page, and release the mouse button.

b.  When the Insert Fireworks HTML window opens, click Browse  and navigate to the
local root folder / images folder, select wms-top.htm, and click Open and then Ok.

c.  Press the <Right> arrow key to deselect the Fireworks object and press the <Enter>
key to space down.

d.  Click on the graphic just placed.  In the Property Inspector panel, Alt text box type in
Wuerkruzen Middle School – Department of Defense Education Activity.

4.  Save File as a Site Template.

a.  Click File > Save As Template.

b.  If not selected, select WMS from the Site: pulldown.

c.  In the Save As: text box, type in basic and click Save.
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5.  Making an Editable Region.

a.  From the menu bar, click Modify > Templates > New Editable Region.

b.  In the New Editable Region window, Name text box, type in Page Title and click Ok.

c.  With the words {Page Title} highlighted, use the Property Inspector panel to change
the text attributes as follows:

Font pulldown: Verdana, Arial, Helvetica
Size pulldown: 3
Color selector: Black #000000
Bold button: Pressed In

d.  Press the <Right> arrow key to deselect the editable region and press the <Enter>
key to space down.

6.  Insert Table.

a. In the Objects panel, click on the Insert Table object tool (2nd down, left-hand column)
and drag it over onto your Web page window below the graphic and blank link you just
created.

b.  In the Insert Table window enter type in Rows: 1, Cell Padding: 5, Columns: 2, Cell
Spacing: 0 (zero), Width: 625, select pixels from the pulldown, and Border: 0 (zero).
Click Ok.

e.  Place your cursor in the first cell of the first row and click.  In the Property Inspector's
W (width) text box, type in 20%.
(Hint: If you do not see the W text box, click the small dark gray triangle at the bottom
right corner of the Property Inspector panel.)

7.  Insert Fireworks Code.

a. In the Objects panel, click on the Insert Fireworks HTML tool (6th down, left-hand
column) and drag it over into the first cell of the table and release the mouse button.

b.  When the Insert Fireworks HTML window opens, click Browse , navigate to the local
root folder / images folder, select wms-menu.htm, and click Open and then Ok.

8.  Insert Skip Navigation Accessibility.

a.  Place your cursor in the second cell of the table and click.

b.  From the menu bar, click Insert > Invisible Tags > Named Anchor.
(Hint:  You can also click the Object Tools Panel pulldown and select Invisibles.  Click
the Insert Named Anchor object (top, left-hand column).)

c.  When the Insert Named Anchor window opens, type in skipnav in the Anchor Name:
text box.  Click Ok.
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d.  Click in the cell, but off of the named anchor icon.  Using the Property Inspector panel
set the Vert pulldown to Top.
e.  From the menu bar, click View > Code to see the HTML code for the template Web
page.

f.  Place your cursor on the beginning of the line (#39) just below the <body
bgcolor="#… line, click, and press the <Enter> key to space down.

g.  On the blank line you just created by pressing the <Enter> key, type in the following,
all on one line.

<A HREF="#skipnav"><img src="../images/ skipnav.gif" alt="Skip Navigation"
border="0"></A>

h.  From the menu bar, click View > Design to switch back to the design view.

9.  Making another Editable Region.

a.  Place your cursor in the second cell and click.

b.  From the menu bar, click Modify > Templates > New Editable Region.

c.  In the New Editable Region window, Name: text box, type in content and Click Ok.
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d.  With the word {content} highlighted, use the Property Inspector panel, change the
text attributes as follows:

Font pulldown: Verdana, Arial, Helvetica
Size pulldown: 2
Color selector: Black #000000
Bold button: Unpressed

10.  Adding Web Page Date.

a.  Using your cursor, click below the table.

b. In the Objects panel, click on the Insert Date tool (5th down, left-hand column) and
drag it over below  the first cell of the table and release the mouse button.

e.  In the Insert Date window, select [No Day] for the Day Format, 03/07/1974 for the
Date Format, and [No Time] for the Time Format.

f.  Click the radio button for Update Automatically on Save .  Click Ok.

g.  If needed, highlight the block of date text with your cursor.

h.  From the menu bar, click Text > Font > Verdana, Arial, … .

i.  From the menu bar, click Text > Font > Size > 1.

11.  Fix Alt Tags when Using Fireworks HTML.

a.  From the menu bar click Edit > Find and Replace.

b.  Set the Find In: pulldown to Current Document.

c.  Set the Search For: pulldown to Source Code  and in the text box to the right type in
spacer.gif" (Do not forget the ending double quotation mark).

d.  In the Replace With: text box type in spacer.gif" alt="" (two double quotation marks
with nothing in between).

e.  Click Replace All.  Click Ok to the replacement warning and click Close  when
finished.  If a Code Inspector window opens, you can close it too.

f.  From the menu bar click File > Save.
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12.  Preview the Web Page.

a.  From the menu bar, click File > Preview in Browser.

b.  Select one of the browsers listed.

c.  When finished viewing the page, close the browser.

13.  Exit Dreamweaver.
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Dreamweaver 4, Lab 6 – Building a Web Page from a Site Template

1.  Start Dreamweaver.

Go to the Site Manager window and select the Web site you wish to work with from the
Site pulldown.  For our lab, select WMS.

2.  Open a New Web Page.

a.  From the Site Manager window menu bar, click File > New from Template.

b.  In the Select Template window, Templates: text box, click basic.  Make sure the
checkbox for Update Page when Template Changes is checked.

c.  Click Select.

3.  Update the Web Page.

a.  Highlight the words {Page Title} in the Page Title editable region.

b.  Type in Contact Info.

c.  Highlight the word {content} in the Content editable region and press the <Delete>
Key.

d.  Click on the Insert Table object (2nd down, left-hand column) and drag it into the
Content editable region.

e.  In the Insert Table window enter type in Rows: 1, Cell Padding: 5, Columns: 2, Cell
Spacing: 0 (zero), Width: 500, select pixels from the pulldown, and Border: 0 (zero).
Click Ok.
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4.  Add text.

a.  In the first cell of the table you just added type in the following text:
(Hint:  Use <Enter> key to double space <P> tag and <Shift-Enter> key combination to
single space <BR> tag.)

Mailing Address

Wuerkruzen Middle School
PSC 485 BOX 99
FPO AP 96321-0099

b.  In the second cell of the table type in:

Telephone Numbers

Main Office:
Local DSN: 712-5434
Commercial: 011-82-55-540-5434
Fax: Local DSN: 712-5435

Athletic Director:
Local DSN: 712-5422
Commercial: 011-82-55-540-5422

Music Director:
Local DSN: 712-5445
Commercial: 011-82-55-540-5445

c.  Change the font, size, color and formatting as you want using the Property Inspector
panel.

d.  Select both cells and change the Vert pulldown to Top.

5.  Save Web Page and Publish.

a.  From the menu bar, click File > Save As.

b.  Navigate to your local root folder and type in contact.htm .  Click Save.

c.  Go to the Site Manager window.
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d.  Click the contact.htm file in the Local Folder side of the Window and click the Check-
In icon.  Anytime you are prompted to enter you password, type in your Student
Password and click Ok.  This is required to complete the connection to the Web Server

e. Since this is the first time these files are being sent to the web server, when prompted
to include Dependent Files, click Yes.  The files including all the required graphic files
you built earlier will be transferred to the Web server.

f.  Click the Netscape Navigator or MS Internet Explorer icon on the desktop or for
Windows, click Start > Programs > Netscape Communicator or Internet Explorer.

g.  In the browser window, Netsite  or Address text box type in http:// followed by the
HTTP Address, a forward slash "/", and your Student username.  You should see your
WMS Homepage displayed.  Click the Contact Info button.

h.  When finished viewing the page, close the browser.

6.  Exit Dreamweaver.
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Dreamweaver 4, Lab 7 – Building a Web Page from a Site Template (2)

1.  Start Dreamweaver.

Go to the Site Manager window and select the Web site you wish to work with from the
Site pulldown.  If WMS is not selected, select WMS.

2.  Open a New Web Page.

a.  From the Site Manager window menu bar, click File > New from Template.

b.  In the Select Template window, Templates: text box, click basic.  Make sure the
checkbox for Update Page when Template Changes is checked.

c.  Click Select.

3.  Update the Web Page.

a.  Highlight the words {Page Title} in the Page Title editable region.

b.  Type in Calendar.

c.  Highlight the word {content} in the Content editable region and press the <Delete>
Key.

4.  Using the Calendar Extension.

a.  From the menu bar, click Insert > Calendar.

b.  In the Insert Calendar window set the Month: pulldown to October, Year: pulldown to
2001, Display Dates: radio button to In Cell.  Leave the other options set to the defaults:
Start Weeks With: Sunday, Days Format: Sun, Empty Frames: Display, and Display
Months: Current Only.

c.  Click Ok.
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d.  Using your cursor, highlight all the cells in the calendar table and using the Property
Inspector panel, change the text's attributes as follows:

Font pulldown: Verdana, Arial, Helvetica
Size pulldown: 2
Color selector: Black #000000
Bold button: Unpressed

e.  Highlight the month and year text and change it's font properties to:

Font pulldown: Verdana, Arial, Helvetica
Size pulldown: 3
Color selector: Dark Blue #000099
Bold button: Pressed in

f.  Place your cursor in the first row (month and year) and click.  Click the color selector
box next to the Bg field.  Using the eye dropper cursor, place it over the clay color in the
menu button background and click.

g.  Click in the cell for October 5th and type in – Band Concert 1930 hrs next to the 5.

h.  Highlight the text entered in the previous step and set the font properties in the
Property Inspector panel as follows:

Font pulldown: Verdana, Arial, Helvetica
Size pulldown: 1
Color selector: Black #000000
Bold button: Unpressed
Link pulldown type in: band2001.htm

5.  Save Web Page and Publish.

a.  From the menu bar, click File > Save As.

b.  Navigate to your local root folder and type in calendar.htm .  Click Save.

c.  Go to the Site Manager window.

d.  Click the calendar.htm  file in the Local Folder side of the Window and click the
Check-In icon.  Anytime you are prompted to enter you password, type in your Student
Password and click Ok.  This is required to complete the connection to the Web Server

e. Since this is the first time these files are being sent to the web server, when prompted
to include Dependent Files, click Yes.  The files including all the required graphic files
you built earlier will be transferred to the Web server.
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f.  Click the Netscape Navigator or MS Internet Explorer icon on the desktop or for
Windows, click Start > Programs > Netscape Communicator or Internet Explorer.

g.  In the browser window, Netsite  or Address text box type in http:// followed by the
HTTP Address, a forward slash "/", and your Student username.  You should see your
WMS Homepage displayed.  Click the Calendar button.

h.  When finished viewing the page, close the browser.

6.  Exit Dreamweaver.
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Dreamweaver 4, Lab 8 – Building a Web Page from a Site Template (3)

1.  Start Dreamweaver.

Go to the Site Manager window and select the Web site you wish to work with from the
Site pulldown.  For our lab, select WMS.

2.  Open a New Web Page.

a.  From the Site Manager window menu bar, click File > New from Template.

b.  In the Select Template window, Templates: text box, click basic.  Make sure the
checkbox for Update Page when Template Changes is checked.

c.  Click Select.

3.  Update the Web Page.

a.  Highlight the words {Page Title} in the Page Title editable region.

b.  Type in Band Concert.

c.  Highlight the word {content} in the Content editable region and press the <Delete>
Key.

4.  Inserting a Graphic.

a.  Using the Insert Image  tool (top, left-hand column), click and drag into the Content
editable area.  Release the mouse button.

b.  Navigate to the local root folder / images folder and click on either band1oval.jpg or
band2frame.jpg.  Click Select.  (Mac note: Click Open.)

c.  Click Ok to the Document Relative  alert box.

d.  In the Property Inspector panel, Alt text box type in Photograph of Concert Band
Playing.

e.  In the Border text box type in 0 (zero) and click the left align button to the right of the
Border textbox.
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5.  Inserting Text.

 a.  Next to the photograph you just placed, type in:

On October 5, 2001, the Wuerkruzen Middle School Concert Band will
perform at 1930 hours in the school auditorium. The group will perform
several new arrangements of old scores. Even though they've only
practiced together for a short time, the group is guaranteed to provide an
evening of eclectic entertainment.

b.  Highlight the text you just entered and change the font properties to:
Font pulldown: Verdana, Arial, Helvetica
Size pulldown: 2
Color selector: Black #000000
Bold button: Unpressed

c.  Click on the photograph.  In the Property Inspector panel, change the Align: pulldown
to Left.

6.  Save Web Page and Publish.

a.  From the menu bar, click File > Save As.

b.  Navigate to your local root folder and type in band2001.htm.  Click Save .

c.  Go to the Site Manager window.

d.  Click the band 2001.htm file in the Local Folder side of the Window and click the
Check-In icon.  Anytime you are prompted to enter you password, type in your Student
Password and click Ok.  This is required to complete the connection to the Web Server

e. Since this is the first time these files are being sent to the web server, when prompted
to include Dependent Files, click Yes.  The files including all the required graphic files
you built earlier will be transferred to the Web server.

f.  Click the Netscape Navigator or MS Internet Explorer icon on the desktop or for
Windows, click Start > Programs > Netscape Communicator or Internet Explorer.

g.  In the browser window, Netsite  or Address text box type in http:// followed by the
HTTP Address, a forward slash "/", and your Student username.  You should see your
WMS Homepage displayed.  Click the Calendar button and click the Band Concert
hyperlink.

h.  When finished viewing the page, close the browser.

7.  Exit Dreamweaver.
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Dreamweaver 4, Lab 9 – Synchronizing Template Hyperlinks

1.  Start Dreamweaver.

Go to the Site Manager window and select the Web site you wish to work with from the
Site pulldown.  If not selected, select WMS.

2.  Open the Template.

a.  Click File > Open.

b.  Navigate to the local root folder / Templates and select basic.dwt.

c.  Click Open.  If prompted to Check Out the file, click Check Out and type in your
username password if requested.

3.  Synchronize Fireworks HTML Links.

a.  Click on the Calendar menu button in the Template window.

b.  In the Property Inspector Panel, click on the Browse for File icon next to the Link text
box.  Navigate to the local root folder and click on the file, calendar.htm .  In the
Relative To: pulldown, select Document.  Click Select. (Mac note: Click Open).

OR

Arrange the Site Manager window and Template window so you can see both. In the
Property Inspector Panel, click on the Point to File icon next to the Link text box and
drag the arrow cursor over the calendar.htm  file name in the Site Manager, Local Folder
window.  Release the mouse button.

c.  Click on the Contact Info menu button.

d.  In the Property Inspector Panel, click on the Browse for File icon next to the Link text
box.  Navigate to the local root folder and click on the file, contact.htm.  In the Relative
To: pulldown, select Document.  Click Select.

e.  Click on the Homepage Hotspot area.

f.  In the Property Inspector Panel, click on the Browse for File icon next to the Link text
box.  Navigate to the local root folder and click on the file, index.html.  In the Relative
To: pulldown, select Document.  Click Select.
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4.  Save Template and Update.

a.  From the menu bar click File > Save.

b.  When prompted to Update all Documents that use this Template , click Yes.
(Mac note: When prompted to Update Template Files, click Update.)

c. When the file update has finished, click Close .

d.  Open the Site Manager Window and Check in all the files that were updated.  If
prompted to Check Out file click, Yes to All.
(Hint:  You can use click and shift-click to select a range of files or click and ctrl-click
to select a specific set of files.)

5.  Test the Web Site.

a.  Click the Netscape Navigator or MS Internet Explorer icon on the desktop or for
Windows, click Start > Programs > Netscape Communicator or Internet Explorer.

b.  In the browser window, Netsite  or Address text box type in http:// followed by the
HTTP Address, a forward slash "/", and your Student username.  You should see your
WMS Homepage displayed.  Click the Calendar, Contact, Homepage , and Band
Concert hyperlinks.

c.  When finished viewing the Web site, close the browser.

6.  Exit Dreamweaver.
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Dreamweaver 4, Lab 10 – Section 508 Accessibility Check

1.  Start Dreamweaver.

Open the Site Manager window and select WMS.

2.  Check Out a Web Page.

a.  Click on one of the four Web pages you built.  If it is not already checked out, click the
Check Out button.

b.  Double click the file name of the Web page you previously checked out to open it.

3.  Check for Accessibility Issues.

a.  To run one of the Accessibility Extensions we installed earlier, from the menu bar,
click Commands > Check page for Accessibility.  Click Ok.  A report will be run and
displayed in your browser with the results.  Look for Priority One  problems.

b.  To run the 508 Accessibility Extension we installed earlier, from the menu bar, click
Accessibility > Evaluate and Fix .

c.  In the Reports window, select Current Document from the Report On: pulldown.

d.  Click the checkbox for 508 Accessibility Suite – Evaluate and Fix.  Click Run.
Look for red X's.

e.  To get a more explanation about your Web page's 508 compliance, click
Accessibility > Evaluate and Fix .  Click Load Page Problems.  A report will be
displayed with the results.  Look for Failed problems.  Click Edit to go to the line of
source code with the problem.  Click View > Code View Options > Line Numbers to
see the line numbers where the problem occurred and you can manually fix the web page
there.  Click Close to exit the 508 Accessibility window.
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f.  If you have made changes to the Web page, click File > Save.

4.  Check-In Your Web Page.

5.  Exit Dreamweaver.

6.  Verify Web Page with Lynx (Windows only).

a.  Windows NT/2000: From the Windows menu bar click Start > Run and type in cmd
and click Ok.

Windows 95/98: From the Windows menu bar click Start > Run and type in command
and click Ok.

b.  Navigate to the directory where Lynx has been installed.  See Dreamweaver course
specifics.  (Example DOS Command: cd \lynx32 and press <Enter>)

c.  Type in lynx and press <Enter>.

d.  Press g and then type in http://, followed by the HTTP address provided earlier, a
forward slash "/", and your User name (e.g., http//192.168.1.10/user2).  Press <Enter>.

e.  Use the up and down arrow keys to go between links and the right arrow to follow
that link.  The left arrow key goes back one page and the space bar scrolls down one
screen.

f.  When finished, press q to quit and y to confirm.


