
DoDEA: Introduction to Macromedia's Fireworks 4

FIREWORKS COURSE OBJECTIVES

 - Basic understanding of graphic types and formats
 - Familiarity with the Fireworks interface
 - Create simple vector graphics with text and effects
 - Work with bitmap images
 - Add interaction to graphics
 - Develop navigation buttons and with rollovers

FIREWORKS 4 COURSE SPECIFICS:

Images Folder:                                                                          

GRAPHIC FORMATS RELATED TO THE WEB

File
Extension

Name Use Description

.png Portable Network
Graphics (PNG)

Any.  Only supported in the
most current browsers.

New W3C bitmap standard to
replace GIFs.  Lossless
compression, transparency,
24-bit color.  Fireworks native
format.

.jpg

.jpeg
Joint Photographic
Experts Group
(JPEG)

Photographs or images with
gradients, blends and
inconsistent colors

Lossy compression,
progressive download, true-
color

.gif Graphics Interchange
Format (GIF)

Graphics with large areas of
single colors

Lossless compression,
transparency, interlaced,
animation, limit of 256 colors
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 DoDEA: Fireworks 4 Lab Exercises

Fireworks 4, Lab 1 – Basic Logo Design

1.  Start Fireworks.

Double-click the Fireworks icon or for Windows, click Start > Programs > Macromedia >
Fireworks 4.

2.  Create a blank canvas to draw on.

a.  On the menu bar, click File > New.

b.  In the "New Document" window, Canvas Size Box:
Set the width to 625 and select pixels from the pulldown menu.
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c.  Set the height to 110 and select pixels.

d.  Set the resolution to 72 and select pixels/inch.

e. In the Canvas Color Box, select white (click the radio button to select).

f.  Click the Ok button.  A blank canvas appears.

3.  Draw rectangles.

a.  In the Tools panel, normally on the left, click on the Rectangle drawing tool (5th tool
down, left-hand column).
(Hint: If you do not see the Tools panel, click Window on the menu  bar and click Tools.)
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b.  In the Colors box of the Tools panel, click the small black triangle next to the pencil
icon and choose the white box with red diagonal line for no stroke.     

c.  Click the small black triangle  next to the paint bucket icon, and click on a fill color of
#000099 (dark blue) to select it.
(Hint:  You can also type in the color's numeric representation and press the Enter Key.)

d. On the menu bar, click View > Rulers.  This will toggle the drawing rulers on or off.

e.  Place the cursor in the middle, left section of the canvas (about 50 pixels down and 10
across), click, and with the mouse button pressed down, drag slowly down about 25
pixels and right about 600 pixels, so that you have a long, thin blue rectangle.  Release
the mouse button to complete the process.  If you make a mistake, press the Delete Key
and try again.
(Hint:  To see real-time information as you draw, click the Info panel or Window > Info
from the menu bar.)

f.  Select the Pointer tool from the Tools panel (top, left-hand tool), and place your cursor
over the rectangle you just drew.  The "selection handles," little red squares, will appear
at the corners of the rectangle.  Click to select it.  The selection handles will turn from red
to blue, letting you know the object has been selected.  With your cursor over the
rectangle, click and drag the dark blue rectangle until it is centered in the canvas (top, left
corner at about 50 down and 10 across).  Release the mouse button to place it.

g.  Click on the Rectangle drawing tool again.

h.  In the color box, select no stroke (white box with red diagonal line) and a fill color of
#CCCC99 (clay).

i.  Place the cursor in the upper left corner of the canvas ( 0 across and 0 down), click,
and with the mouse button pressed down, drag slowly down about 100 pixels and right
about 80 pixels so that you have a rectangular square.  Release the mouse button. This
rectangular square will overlap the dark blue rectangle.

4.  Arrange order.  For our purposes, we want the blue rectangle to appear on top of the clay
rectangle.

a.  Click the Pointer tool, if not selected, and click on the dark blue rectangle to select it.
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b.  On the menu bar, click Modify  > Arrange > Bring to Front.  The dark blue rectangle
should now appear on top of the clay colored rectangular square.

5.  Add text.

a.  Click on the Text tool in the Tools panel (5th tool down, right-hand column).  Place the
cursor in the lower, middle section of the canvas, and click.  The "Text Editor" window will
open.

b.  Select Times New Roman from the Font pulldown.

c. To the right of the Font pulldown is the Font Size pulldown slider.  Click the pulldown
and use the slider to select 34 or type in 34.

d.  From the color selector, select #000000 (black).

e.  If the bold face (B), italics (I), or underline (U) button(s) are pressed in, click the
appropriate button(s) to deselect them.  (There are many other options for font sizing,
spacing, alignment, and direction that can be applied to text changing its appearance.
The Anti-Alias pulldown controls the level of blur added to the text to eliminate the "stair
step" appearance of diagonal lines.)

f.  Place your cursor in the large text box and click.  Type in Wuerkruzen Middle School
and click Ok.

g.  With the text selected, click and drag the text to the middle of the bottom portion of the
canvas underneath the dark blue rectangle.

6.  Multiple object selection and special effects.

a.  With the Pointer tool selected, click on one of the three objects on the canvas.  The
selection handles will turn blue.

b.  Move your cursor to the next object.  With the Shift key held down, click on that
object.  The selection handles for that object will also turn blue.

c.  Repeat the above step for the third object.
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d.  With all three objects selected, click on the Effect panel or Window > Effect from the
menu bar.

e.  Click on the Add Effects pulldown (None is the default).  Select Shadow and Glow >
Drop Shadow.  Click the Distance pulldown (top, left) and select 5. Place the cursor in
an empty section of window and click.

f.  To deselect the selected objects, place the cursor in an empty section of the canvas
and click.

7.  Importing graphics from other sources.

a.  From the menu bar, click Insert > Image .  Navigate to the Images folder and select
dodea.psd (a Photoshop graphic) and click Open.

b.  Place the cursor at the top center of the canvas and click.  The graphic will appear on
the canvas and already be selected.

c.  Click on the graphic and drag it to the upper right corner of the canvas.  Release the
mouse button to place the graphic.

8.  Adding additional text.

a.  Click on the Text tool in the Tools panel, place the cursor above the dark blue
rectangle to the right of the clay colored rectangular square, and click.  The "Text Editor"
window will open.

b.  Select Arial from the Font pulldown.

c.  Click the Font Size pulldown slider and select 8 or type in 8.

d.  From the color selector, select #000000 (black).

e.  If the bold face (B), italics (I), or underline (U) button(s) are pressed in, click the
appropriate button(s) to deselect them.

f.  Place your cursor in the large text box and click.  Type in DEPARTMENT OF
DEFENSE EDUCATION ACTIVITY and click Ok.

h.  With the text selected, position the text just above the dark blue rectangle and just to
the right of the clay colored rectangular square (approximately 90 across, 30 down).

9.  Saving and exporting graphics.

a.  To export the file so it can be used on your Web page, from the menu bar click File >
Export Preview.  From this window, various settings can be adjusted to optimize the
graphic (minimize file size and maximize image quality) and set image transparency (.gif
only).
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b.  Click the Options tab in the upper left corner and select GIF from the Format
pulldown.  Select WebSnapAdaptive  (Mac note: Web Adaptive) from the Palette
pulldown and click Export.

c.  Navigate to the Images folder and type in, wms-logo.gif, for the filename.  The Save
as Type pulldown (Mac note: Save As) should be set to Images Only.

d. Click Save.

e.  To save the graphic image in native format (.png) so the image can be edited and
reused in the future, on the menu bar click File > Save As.  Navigate to the Images
folder and type in the filename, wms-logo.png.  Click Save .

10.  Exit Fireworks.

To exit Fireworks, from the menu bar, click File > Exit.

11.  Finished graphic.
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Fireworks 4, Lab 2 – Web Page Masthead Design

1.  Start Fireworks.

2.  Open a previous graphic.  For this lab, we will be working with the graphic created in
Fireworks 4, Lab 1.

a.  On the menu bar, click File > Open.  Navigate to the Images folder, click on wms-
logo.png to select it, and click Open.
(Hint:  If you did not complete lesson 1, navigate to the Solution/Images folder on the
CD-ROM and select wms-logo.png from there.)

b. Save the graphic to a new file. On the menu bar click File > Save As and navigate to
the Images folder.  Type in the filename, wms-top.png, and click Save.

3.  Modify objects in a graphic.

a.  Click on the Pointer tool from the Tools panel (top, left).

b.  Move the cursor over the text, DEPARTMENT OF DEFENSE EDUCATION
ACTIVITY.  When the selection handles, small red squares, appear at the corners of the
object, click to select it.

c.  Press the Delete key, or from the menu bar, click Edit > Cut, to remove the object
from the canvas.
(Hint:  Fireworks maintains a history of the changes you make.  On the menu bar, click
Edit > Undo … to back up step-by-step, or click Edit > Redo … to reapply changes.
There is also a History panel available (Window > History) that functions like a recorder
tracking your changes which you can use to reverse and replay changes.)

d.  Move the cursor over the dodea logo object.  When the selection handles appear at
the corners of the object, click to select it.

e.  Press the Delete key, or cut the object from the canvas using Edit > Cut on the menu
bar.

f.  If the rulers are not visible, on the menu bar click View > Rulers.

g.  Move the cursor over the Wuerkruzen Middle School text.  When the selection
handles appear at the corners of the object, click it to select it.

h.  Double-click the object to open the "Text Editor" window.

i.  The words Wuerkruzen Middle School should already be selected.  If not, click in the
large text box before the "W."  Click and, with the mouse button pressed down, drag the
cursor to the right, highlighting the words.  Release the mouse button.

j. Click the Font Size pulldown, and use the slider to select 22 or type in 22.  Click Ok.

k.  With the text selected, position the text on the right side of the canvas just above the
dark blue rectangle and just left of the right edge of the canvas (350 across, 15 down).
There should be a small border of the canvas around the object.
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4.  Add text.

a.  Click on the Text tool in the Tools panel.  Place the cursor in the rightmost third of the
dark blue rectangle and click.  The "Text Editor" window will open.

b.  Select Arial from the Font pulldown, a font size of 12, the color #FFFFCC (cream),
and click the Bold (B) button to select it.  When selected the button will appear pressed
in (Mac note: appears a darker shade).

c.  Place your cursor in the large text box and click.  Type in Homepage  and click Ok.

d.  With the text selected, position the text in the middle, right of the dark blue rectangle
(about 530 across, 50 down).

e.  Repeat steps a. and b.

f.  Place your cursor in the large text box and click.  Type in Sitemap and click Ok.

g.  With the text selected, position the text in the middle of the dark blue rectangle just to
the left of the word Homepage (about 460 across, 50 down).

5.  Align objects.

a.  Select the Pointer tool and click on one of the two word objects you just created.  The
selection handles will turn blue.

b.  Move your cursor to the other word object.  With the Shift key held down, click on it.
The selection handles for that object will also turn blue.

c.  With both word objects selected, from the menu bar click on Modify > Align > Top.
This will line up the top edge of the two word objects.
(Hint:  With an object(s) selected you can use the up, down, left, and right arrow keys to
move the object(s) pixel by pixel.)

6.  Add interaction to a graphic.    Creating a Client-Side Image Map with Hotspots.

a.  Select the Rectangular Hot Spot tool from the Tools panel (10th down, left-hand
column).

b.  Place the cursor above and to the left of the word Sitemap, and click the mouse
button.  With the mouse button pressed, drag the cursor towards the bottom, right corner
of the word Sitemap, going slightly past it.  Release the mouse button and the Object
panel should appear.
(Hint:  If the Object panel is not displayed, click Window > Object on the menu bar.)
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c.  In the Object panel, click in the Current URL pulldown next to the chain link icon,
remove any existing text, and type in sitemap.html.

d.  Click in the Alt Tag text box next to the <Alt> icon and type in Link to Sitemap.

e.  Leave the Link Target pulldown next to the target icon set to None and the Hotspot
Shape  pulldown set to Rectangle.  Click in the canvas to apply.

(Hint:  Using Hotspots and Slices activate the Web Layer.  Layers are overlays on the
canvas.  Click the "eye" icon to hide and unhide the layer allowing you to edit the
appropriate object.)

f.  Repeat steps a. and b. for the Homepage  text object.

g.  In the Object panel, click in the Current URL pulldown next to the chain link icon,
remove any existing text, and type in index.html.

h.  Click in the Alt Tag text box next to the <Alt> icon and type in Link to Homepage .

i.  Leave the Link Target pulldown next to the target icon set to None and the Hotspot
Shape  pulldown set to Rectangle.  Click in the canvas to apply.

7.  Saving and exporting graphics.

a.  To export the file so it can be used on your Web page, on the menu bar click File >
Export Preview.  From this window, various settings can be adjusted to optimize the
graphic (minimize file size and maximize image quality) and set image transparency (.gif
only).

b.  Click the Options tab in the upper left corner and select GIF from the Format
pulldown.  Select WebSnapAdaptive  (Mac note: WebAdaptive) from the Palette
pulldown and click Export.

c.  Navigate to the Images folder and type in wms-top.gif, for the filename.

d.  Click the Save as Type (Mac note: Save As) pulldown and select HTML and Images.
The file extension should change from .gif to .htm.

e. Click Save.
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f.  On the menu bar click File > Save, or if you did not save the graphic in step 2.b., click
Save As, navigate to the Images folder, and type in the filename wms-top.png.  Click
Save .

8.  Exit Fireworks.

9.  Finished graphic.
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Fireworks 4, Lab 3 – Working with Existing Graphics

1.  Start Fireworks.

2.  Open a bitmap graphic.

On the menu bar, click File > Open.  Navigate to the Images folder, click on band1.jpg
to select it, and click Open.
(Hint: The graphic will open surrounded by a blue and black striped border and the words
"Bitmap Mode" will appear in the window title.  These are indicators to let you know that
you are working in Bitmap Mode and not Vector Mode.)

3.  Modifying an existing graphic.

a.  In the Tools panel, click on the small black triangle of the Marquee tool (2nd down, left-
hand column).

b.  Click and move your cursor to the right over the Oval Marquee selection and release
the mouse button to select it.

c.  Place the cursor in the bottom, right portion of the graphic.  Click and drag the cursor
up and to the left creating an oval covering most of the image and release the mouse
button.
(Hint:  Do not worry the oval is not placed exactly where you want it.  We will move it
later.)

d.  Place the cursor inside the oval marquee you just drew, click and drag the oval over to
center it over the picture.  Release the mouse button.

e.  On the menu bar, click Modify > Marquee > Feather.  A text box will display asking
you the number of pixels to feather.  Enter 15 and click Ok.
(Hint:  If nothing appears to happen, do not worry. We’re not quite finished.)

f.  On the menu bar, click Modify > Marquee > Select Inverse .

g.  Press the Delete key to remove the area outside the oval marquee.

h.  Click the small red circle with the white "X" at the bottom of the window, or select
the Pointer tool and double click in the graphic to exit the Bitmap editing mode.  You
should now see the picture in the oval with edges that blend into the background.

i.  On the menu bar, click Modify > Trim Canvas to remove any extra canvas.

4.  Saving and exporting graphics.

a.  To export the file so it can be used on your Web page, on the menu bar click File >
Export Preview.
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b.  Click the Options tab in the upper left corner and select JPEG from the Format
pulldown.  Select 80 from the Quality pulldown and No smoothing (Mac note: 0 ) from
the Smoothing pulldown. The defaults for Progressive (unchecked) and Sharpen
Color Edges and Remove Unused Colors (checked) are fine.  Click Export.

c.  Navigate to the Images folder and type in band1oval.jpg for the filename.

d.  If needed, click the Save as Type (Mac note: Save As) pulldown and select Images
Only.

e. Click Save.

f.  From the menu bar click File >  Save As, navigate to the Images folder, and type in
the filename, band1oval.png.  Click Save.

5. Exit Fireworks.

If prompted to save changes to band1.jpg, click No.

6.  Finished graphic.
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Fireworks 4, Lab 4 – Working with Existing Graphics (Continued)

1.  Start Fireworks.

2.  Open a bitmap graphic.

On the menu bar, click File > Open.  Navigate to the Images folder, click on band2.jpg
to select it, and click Open.
(Hint: The graphic will open surrounded by a blue and black striped border and the words
"Bitmap Mode" will appear in the window title.  These are indicators to let you know that
you are working in Bitmap Mode and not Vector Mode.)

3.  Obtaining information on an existing graphic.

a.  At the bottom of the graphic window, please take note of the size, in pixels, of the
graphic.  You can also obtain the same information by clicking the Info panel.  If the Info
panel is not available, click Window > Info from the menu bar.

b.  Record the Width and Height.  Width:                        Height:                         

4.  Create a blank canvas.

a.  On the menu bar, click File > New.

b.  In the "New Document" window, canvas size box:
Set the width to 20 pixels wider than the Width in 3.b. above.  If not selected, select
pixels from the pulldown menu.

c.  Set the height to 20 pixels longer than the Height in 3.b. above.  If not selected,
select pixels from the pulldown menu.

d.  If not selected, set the resolution to 72 and select pixels/inch from the pulldown.

e. In the canvas color box:
Click to select the radio button for Custom and using the color selector box choose a
background color of our choice.

f.  Write down the background color number for use later:  Background color: #               

g.  Click the Ok button.

5.   Copying between windows.

a.  Click in the title bar at the top of the band2.jpg window  to make it active.  Click
again, hold down the mouse button, and drag the window so you can see most of each
window.  Some overlap is Ok.

b.  Click in the center of the bitmap image to select it.  The image is selected when you
see the small blue squares on the corners of the picture.

c.  Click the selected image, hold down the mouse button, and drag the bitmap image
over top of the Untitled Window's canvas.  Release the mouse button.
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(Hint:  You can also click Edit > Copy on the menu bar, click the Untitled window with
your selected background color, and on the menu bar, click Edit > Paste.  If prompted to
resample the image because of different resolutions, click Don't Resample.)

d.  Click the Info panel. If the Info panel is not visible, click Window > Info on the menu
bar.

e.  While watching the Info panel's X-Y coordinates, use the arrow keys to move the
selected bitmap image you just copied to an X coordinate of 10 and an Y coordinate of
10.  This will center our image on the background since our background is 20 pixels wider
and 20 pixels longer than our bitmap image.

6.  Applying special effects.

a.  Click on the Effect panel or click Window > Effect on the menu bar.

b.  Click on the Add Effects pulldown (None is the default) and select Bevel and
Emboss > Outer Bevel.

c.  Click the Bevel Edge Shape  pulldown and select Ruffle.

d.  Click the Width pulldown slider and select 10.

e.  Click the small black triangle on the corner of the color selector and select the color
you previously used for the background of your canvas.  Hint:  You can also type in the
color number from step 4.f. and press the Enter Key.

f.  Leave all other effect option pulldowns defaulted (Contrast - 75%, Softness – 3, Angle
– 135, and Button Preset – Raised) or have fun and experiment.

7.  Optimizing graphics for smaller Web download

a.  At the top of the graphic window, just below the title bar, click the 2-up tab.  Two
windows will open usually displaying your original graphic on the left and the Export
Preview version on the right.  The Export Preview version will have numbers identifying
the file size when exported and estimated download time.

b.  Click the Optimize panel  to open it.  If the Optimize panel  is not available, click
Window > Optimize.

c.  Click on the Export Preview image to select it.

d.  Click the Settings pulldown and select JPEG – Better Quality.  Note the size and
estimated download time of the file.

e.  Click the Quality pulldown slider and vary setting between 40 and 80 until you find the
smallest setting that does not appreciable change the image quality, about 60.  Note the
file download time is cut in half.

8.  Saving and exporting graphics.

a.  To export the file so it can be used on your Web page, on the menu bar click File >
Export Preview.
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b.  Click the Options tab in the upper left corner and select JPEG from the Format
pulldown.  If not selected, select 60 from the Quality pulldown, No smoothing from the
Smoothing pulldown and click Export.

c.  Navigate to the Images folder and type in, band2frame.jpg, for the filename.

d.  If needed, click the Save as Type (Mac note: Save As) pulldown and select Images
Only.

e. Click Save.

f.  From the menu bar click File > Save As, navigate to the Images folder, and type in
the filename, band2frame.png.  Click Save.

9.  Exit Fireworks.

If prompted to save changes to band2.jpg, click No.

10.  Finished graphic.



16

Fireworks 4, Lab 5 – Rollover Buttons

1.  Start Fireworks.

2.  Create a blank canvas to draw on.

a.  On the menu bar, click File > New.

b.  In the "New Document" window, Canvas Size Box:
Set the width to 125 and select pixels from the pulldown menu.

c.  Set the height to 200 and select pixels.

d.  Set the resolution to 72 and select pixels/inch.

e. In the Canvas Color Box, select white (click the radio button to select).

f.  Click the Ok button.  A blank canvas appears.

3.  Make the button "Up" state.

a.  On the menu bar, click Insert > New Button.  The button editor window (a.k.a.,
Symbol Editor) will appear.  Use the tools in the Tools panel and various panels to design
the "Up" and "Over" states of the button.

b.  In the Tools panel click on the Rectangle drawing tool (5th tool down, left-hand
column).
(Hint: If you do not see the Tools panel, click Window on the menu bar and click Tools.)

c.  In the Colors box of the Tools panel, click the small black triangle next to the pencil
icon and choose the white box with red diagonal line for no stroke.     

d.  Click the small black triangle next to the paint bucket icon, and click on a fill color of
#CCCC99 (clay) to select it.
(Hint:  You can also type in the color's numeric representation and press the Enter Key.)

e.  Use the rulers.  Starting about –50 pixels left and up about 10, click, and with the
mouse button pressed down, drag slowly down about 15 pixels and right about 100
pixels, so that you have a long, thin clay rectangle.  Release the mouse button to
complete the process.  Use the Left, Right, Up, and Down arrow keys to roughly center
the rectangle on the center of the button canvas.  If you make a mistake, press the
Delete Key and try again.

f.  Click on the Text tool in the Tools panel (5th tool down, right-hand column).  Place the
cursor in the center of the clay rectangle in the button the canvas, and click.  The "Text
Editor" window will open.
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g.  Select Arial from the Font pulldown.

h.  To the right of the Font pulldown is the Font Size pulldown slider.  Click the pulldown
and use the slider to select 10 or type in 10.

i.  From the color selector, select #000099 (dark blue).

j.  Click the bold face (B) button to select Bold.  It should appear "pressed in" when
selected.  If the Italics (I) or underline (U) button(s) are pressed in, click the appropriate
button(s) to deselect them.

k.  Place your cursor in the large text box and click.  Type in Calendar.

l.  Using your mouse, highlight the word Calendar.

m.  Below the Font pulldown is the Kerning pulldown slider.  Click the pulldown and use
the slider to select 5% or type in 5%.  (Hint: Kerning is the spacing between characters .)

n.  Click Ok.

o.  With the text selected, use the arrow keys to move the text to the middle center of the
clay rectangle.

p. Select the Pointer tool from the Tools panel (top, left-hand tool).  The text you just
added should already be selected.  If not, place your cursor over the text you just added
and click to select it.  The selection handles will turn from red to blue, letting you know the
object has been selected.

q.  With the Pointer tool selected, place you place your cursor over the clay rectangle so
you can see the red selection handles, hold down the Shift key, and click to select it.
Both the text and clay rectangle should have the blue selection handles visible.

r.  On the menu bar, click Modify  > Align > Center Vertical.

s. On the menu bar, click Modify  > Align > Center Horizontal.  The text should be
placed exactly in the center and middle of the clay rectangle.

t.  With the Pointer tool selected, click in an empty area of the button canvas to clear the
selection handles from the rectangle and the text.

u.  Re-select the clay box, click on the Effect panel or Window > Effect from the menu
bar.

v.  Click on the Add Effects pulldown (None is the default).  Select Bevel and Emboss >
Outer Bevel.
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w.  Click the Bevel Edge Shape  pulldown (top, center) and select Frame1.

x.  Click the Width pulldown (top, left) and select 4.

y.  From the color selector, select #CCCC99 (clay).

z.  Click on the Add Effects pulldown (Untitled is now the default).  Select Shadow and
Glow > Drop Shadow.  Click the Distance pulldown (top, left) and select 5. Place the
cursor in an empty section of button canvas and click.

4.  Making the button "mouse over" state.

a.  Click the Over tab to select it and click on the Copy Up Graphic button.

b.  Click the Onion Skinning checkbox to remove the checkmark.
(Hint: Onion skinning is a function that allows you to view all the states of a button at
once with non-active states opaquely showing through.)

d.  Double click the text you entered to select it. From the color selector, select #FFFFCC
(light cream).  Click Ok.

e.  Double click the clay button to select it and click the color selector in the Tools panel,
select #000099 (dark blue).

f.  With the dark blue box selected, click on the Effect panel or Window > Effect from
the menu bar.

g.  Double click the Drop Shadow effect. Change the distance to 3.  Click in an empty
area of the button canvas to de-select it.

5.  Making the button's active area.

a.  Click the Active Area tab to select it.  You will see a light green rectangle (or slice)
surrounding the button over state.

b.  Click the Pointer tool and use it to click the light green rectangle to select it.

c.  With the light green rectangle selected, place the cursor on the top left selection
handle.  Click and drag to resize the box so it fits closely around the top left corner of the
button.  You want to leave a few pixels of slice space on the top and left sides.

d.  Click on the bottom right selection handle and click and drag up and to the left.  This
time leave a larger amount of excess slice space to the right and bottom of the button.
This will account for the larger drop shadow of the over state.

e.  Click the Link Wizard button.  When the Link Wizard window opens, click the Link
tab.

f.  In the URL text box (next to chain link icon), type in calendar.htm .

g.  In the <Alt> text box, type in Link to Calendar.

h.  Click Ok and close the button window.  A button should appear on your canvas as a
symbol.  If you click on the Library panel (Window > Library from the menu bar) you will
see the button you just created in the library.
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i.  To change the default name of the button symbol, click on the symbol named "button"
and click the small gray letter "i" inside the dark blue circle at the bottom of the Library
panel.

j.  In the Name text box, type in calendar and click Ok.
n.  Close the button editor window.

o.  On the canvas, click and drag the light green slice to position the calendar button at
the top left corner of the canvas.  Release the mouse button.

6.  Making additional buttons.  The button you created is now a symbol in the library, available
for re-use.

a.  Open the Library panel, or if it is not already on-screen click Window > Library from
the menu bar.

b.  Click on the calendar button in the Library panel and drag it onto the canvas, below
the first button.

c.  Double click in the green slice area for this new button and when asked to edit this
instance of all instances, click Current.

d.  The symbol editor window will open and an instance of the calendar button is
displayed.  Double click the "calendar" text to open the text editor.  Replace the word
calendar with the words Contact Info.  Click Ok.

e.  When asked to update the text in other button states, click Yes.

f.  Click the Up tab.  With the Pointer tool, select the Contact Info text and the button.  On
the menu bar, click Modify > Align > Center Vertical.  Repeat this step for the image in
the Over tab.

g.  Click the Active Area tab and click on the Link wizard button.

h.  When the Link Wizard window opens, click the Link tab.

i.  In the URL text box (next to chain link icon), type in contact.htm.

j.  In the <Alt> text box type in Link to Contact Information.

k.  Click Ok and close the button window.  The new button should appear on your
canvas.

l.  Change the default name of this button symbol, click on the symbol named "calendar1"
(or something similar) and click the small gray letter "i" inside the dark blue circle at the
bottom of the Library panel.

m.  In the Name text box, type in contact and click Ok.

n.  Close the button editor window.
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o.  On the canvas, click and drag the light green slice to position the contact button below
the calendar button.  Release the mouse button.
(Hint: Use the arrow keys for fine movement of the slice.)

p.  Repeat step 6 creating 3 more buttons:

Button Text Button URL Button Alt Button Name
Policies policy.htm Link to Policies policy
Sports sport.htm Link to Sports sports

Transportation transport.htm Link to Transportation transport

7.  Saving and exporting buttons.

a.  On the menu bar, click Modify > Trim Canvas to clear away any extra canvas.

b.  To export the file so it can be used on your Web page, from the menu bar click File >
Export Preview.  From this window, various settings can be adjusted to optimize the
graphic (minimize file size and maximize image quality) and set image transparency (.gif
only).

c.  Click the Options tab in the upper left corner and select GIF from the Format
pulldown.  Select WebSnapAdaptive  (Mac note: Web Adaptive) from the Palette
pulldown and click Export.

d.  Navigate to the Images folder and type in, wms-menu.htm , for the filename.  The
Save as Type  pulldown (Mac note: Save As) should be set to HTML and Images.

e. Click Save.

f.  To save the graphic image in native format (.png) so the image can be edited and
reused in the future, on the menu bar click File > Save As.  Navigate to the Images
folder and type in the filename, wms-menu.png.  Click Save .

8.  Exit Fireworks.

9.  Finished graphic.


